COMPUTER Frage : So lernt Excel zählen

An Reinhold Scheck Experte für Windows- und Office-Fragen

An Reinhold Scheck

Ich habe eine Excel-Liste mit Texteinträgen unterschiedlicher Art und wechselnder Zahl. Wie kann ich auf einfache Weise die Anzahl der Einträge herausfinden?

In Excel gibt es viele Möglichkeiten, Listen einzurichten oder Einträge zu zählen. Einige Beispiele dazu, die in den Excel-Versionen ab 97 funktionieren: Im einfachsten Fall stehen die Einträge untereinander in einer einzigen Spalte, etwa im Zellbereich B10:B50. Schreiben Sie in eine Zelle darüber oder darunter die Formel =ANZAHL2(B10:B50). Excel zählt nun in diesem Bereich die Anzahl von Einträgen, unabhängig davon, welcher Art sie sind. Wichtig: ANZAHL2 ist nicht zu verwechseln mit der Funktion ANZAHL. Wenn Ihre Liste mehrere Spalten hat, deren Inhalte einzeln zu zählen sind, ist jeder Spalte eine entsprechende Formel zuzuordnen. Wenn sich die Zählung hingegen auf alle Spalten der Liste beziehen soll, genügt eine einzige Formel, die alle Zellen des Bereichs einbezieht, also etwa =ANZAHL2(D10:G50).

Sehr viel effizienter und variantenreicher einsetzbar ist die Zählung bestimmter Inhalte: Angenommen im Zellbereich B10:B50 steht eine häufig wechselnde Anzahl verschiedener Texte, beispielsweise A, B und C. Sie wollen wissen, wie viele A enthalten sind. Solche Wünsche erfüllt die Funktion ZÄHLENWENN. Mit der Formel =ZÄHLENWENN(B10:B50;„A“) erreichen Sie Ihr Ziel (der Suchbegriff A muss in diesem Fall in Anführungszeichen stehen). Eleganter wird es, wenn Sie den Suchbegriff nicht in die Formel setzen, sondern in eine andere Zelle, auf die sich dann mit Ihrer Formel beziehen. Am Beispiel: Schreiben Sie in die Zelle C8 den Suchbegriff A (jetzt ohne Anführungszeichen) und in die Nachbarzelle B8 die Formel =ZÄHLENWENN(B10:B50;C8). Sie können jetzt in der Zelle C8 jeden anderen Suchbegriff eingeben, ohne die Zählformel anpassen zu müssen. Foto: Q

– Haben Sie auch eine Frage?

 Dann schreiben Sie uns:

E-Mail: computer@tagesspiegel.de

0 Kommentare

Neuester Kommentar
      Kommentar schreiben